Habe mir eine WebApp für den Batterie-Status gebaut

Re: Habe mir eine WebApp für den Batterie-Status gebaut

Beitragvon LocutusB » Mi 3. Mai 2017, 13:05

Na ja, Du kannst über das Widget eine Website zum Fahrtende aufrufen. Die müsste dann, ggf. über einen kleinen Zeitraum, prüfen ob der i3 lädt und im Fall von JA die periodische Aufzeichnung starten und bis zum Ladeende fortführen.
BMW i3 - EZ 02/14 - 80tkm - 13,3kWh/100km (App), 15,5kWh/100km (Zähler) - Entwicklungsstand I001-17-07-500 - Stand 08/17
Benutzeravatar
LocutusB
 
Beiträge: 1171
Registriert: Di 22. Okt 2013, 18:30
Wohnort: MUC

Anzeige

Re: Habe mir eine WebApp für den Batterie-Status gebaut

Beitragvon endurance » Mi 3. Mai 2017, 17:07

OK ein workaround - werde ich mir dann mal genauer anschauen.
PV 18,2kWp - BHKW EcoPower 1.0, 30kWh LiON Sunny Island System
BMW i3 60Ah (Verbrauch ca. 13,8kWh/100km; SW: I001-16-07-506) - Technikblog: https://okedv.dyndns.org/wbb/wcf/
Benutzeravatar
endurance
 
Beiträge: 3395
Registriert: Sa 28. Dez 2013, 20:01
Wohnort: Bei Stuttgart

Re: Habe mir eine WebApp für den Batterie-Status gebaut

Beitragvon fridgeS3 » Fr 1. Sep 2017, 13:32

@systematic wäre es einfach, in der .htaccess den redirect von http auf https für alle Aufrufe zu "gestalten"? Ich bin da etwas überfordert mit dem Syntax
BMW i3 - 60Ah - BEV (Baudatum 09-2013) - I001-17-07-500 - max. SoC 19,4kWh nach 17,8kWh (Erläuterungen zum kWh-Update siehe hier)

Mach' mit und sei ein Teil des BMW i-Team zur eRuda 2018 ; wir freuen uns auf jeden i3-Driver
Benutzeravatar
fridgeS3
 
Beiträge: 2091
Registriert: Di 8. Sep 2015, 13:38
Wohnort: Berlin

Re: Habe mir eine WebApp für den Batterie-Status gebaut

Beitragvon TMi3 » Fr 1. Sep 2017, 13:50

Wenn Du ModRewrite am Webserver hast, sollte so was gehen:
RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R,L]
TMi3
 
Beiträge: 513
Registriert: Do 21. Jul 2016, 11:32

Re: Habe mir eine WebApp für den Batterie-Status gebaut

Beitragvon fridgeS3 » Fr 1. Sep 2017, 15:38

TMi3 hat geschrieben:
Wenn Du ModRewrite am Webserver hast, sollte so was gehen:


:oops: :oops: wie kann ich das bei einer bei 1&1 gehosteten Domain feststellen??
BMW i3 - 60Ah - BEV (Baudatum 09-2013) - I001-17-07-500 - max. SoC 19,4kWh nach 17,8kWh (Erläuterungen zum kWh-Update siehe hier)

Mach' mit und sei ein Teil des BMW i-Team zur eRuda 2018 ; wir freuen uns auf jeden i3-Driver
Benutzeravatar
fridgeS3
 
Beiträge: 2091
Registriert: Di 8. Sep 2015, 13:38
Wohnort: Berlin

Re: Habe mir eine WebApp für den Batterie-Status gebaut

Beitragvon TMi3 » Fr 1. Sep 2017, 15:40

Ins .htaccess rein und dann sieht man es schon. :)
TMi3
 
Beiträge: 513
Registriert: Do 21. Jul 2016, 11:32

Re: Habe mir eine WebApp für den Batterie-Status gebaut

Beitragvon fridgeS3 » Fr 1. Sep 2017, 16:36

Okay, soweit passt das. Jetzt hängt es an anderer Stelle... Hhmm
BMW i3 - 60Ah - BEV (Baudatum 09-2013) - I001-17-07-500 - max. SoC 19,4kWh nach 17,8kWh (Erläuterungen zum kWh-Update siehe hier)

Mach' mit und sei ein Teil des BMW i-Team zur eRuda 2018 ; wir freuen uns auf jeden i3-Driver
Benutzeravatar
fridgeS3
 
Beiträge: 2091
Registriert: Di 8. Sep 2015, 13:38
Wohnort: Berlin

Re: Habe mir eine WebApp für den Batterie-Status gebaut

Beitragvon allesinobi » So 17. Sep 2017, 19:16

Hallo zusammen

habe mir die Webapp (https://github.com/sergejmueller/battery.ebiene.de) von github heruntergeladen und auf meinem Server installiert. Das funktionierte soweit einwandfrei. Jedoch kann ich die Anzeige des Batteriestatus auf meinem Mobiltelefon (Nexus 6P), nachdem einmal ein Wert geladen wurde, nicht aktualisieren. Erst nach dem Löschen des Verlaufs (inkl. Cache) wird der korrekte Wert angezeigt. Hat jemand eine Idee woran das liegen könnte?
Bild
allesinobi
 
Beiträge: 9
Registriert: So 27. Aug 2017, 13:20
Wohnort: Solothurn (Schweiz)

Re: Habe mir eine WebApp für den Batterie-Status gebaut

Beitragvon Xiberger » So 24. Sep 2017, 21:35

Hallo Rewrite Engine Experten,

ich wollte mir die App jetzt auch installieren und kämpfe schon seit 3h mit der Rewrite Engine und deren Syntax - das ist ja Teufelszeugs.

Bevor ich jetzt frustriert aufgebe, vielleicht kann mir ein Experte unter Euch die Einträge für die simple Anforderung nennen:

https://meine.domain.com:12345/

ist der Link auf meine virtual host domain (port basiert), die ich auf meiner Synology angelegt habe.

Wie schaut der dazu passende Rewrite Eintrag aus ? Ich habe diverse Möglichkeiten durchprobiert und erhalte 424, 500 und weitere Error Codes... manchmal einen "Updating Kreis", manchmal nur Fehlermeldungen, manchmal eine weiße Seite, in der Console kommen blocked, err, connrefused, usw. Fehlermeldungen, manchmal werden Teile der Seite geladen, manchmal nicht... es ist ist zum Verzweifeln... und ich bin mir sicher, die Lösung ist ein simpler Zweizeiler...

Vielen Dank für Eure Hilfe und Grüße,
Stefan
i3 Rex (94Ah) Protonic Blue und Atelier (seit 10/2016), KTM Macina Sport 10 CX5 EBike, BMW Z4 M Coupe interlagos blau als Sammlerfahrzeug
Benutzeravatar
Xiberger
 
Beiträge: 118
Registriert: Mi 22. Apr 2015, 19:57

Re: Habe mir eine WebApp für den Batterie-Status gebaut

Beitragvon endurance » Mo 25. Sep 2017, 15:09

Irgendwie versteh ich Euch nicht was fummelt Ihr eigentlich alle mit rewrites herum? Wegen HTTPS? Warum gebt Ihr nicht direkt HTTPS://... an oder macht ein simples Forward?

z.B. via falls ihr nach einer Sekunde umlenken wollt....
<meta http-equiv="refresh" content="1; URL=https://okedv.dyndns.org/port">
geht nat. auch anders nur ein Beispiel
PV 18,2kWp - BHKW EcoPower 1.0, 30kWh LiON Sunny Island System
BMW i3 60Ah (Verbrauch ca. 13,8kWh/100km; SW: I001-16-07-506) - Technikblog: https://okedv.dyndns.org/wbb/wcf/
Benutzeravatar
endurance
 
Beiträge: 3395
Registriert: Sa 28. Dez 2013, 20:01
Wohnort: Bei Stuttgart

Anzeige

VorherigeNächste

Zurück zu i3 - Laden, Ladeequipment

 
  • Ähnliche Themen
    Antworten
    Zugriffe
    Letzter Beitrag
  • Ähnliche Artikel im Blog

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste