https (SSL) Zugang zum Forum

Ankündigungen, Anregungen, Kritik, Verbesserungsvorschläge

Re: https (SSL) Zugang zum Forum

menu
Benutzeravatar

folder Di 5. Aug 2014, 13:53

Guy hat geschrieben:Wenn verschlüsselt, dann mit einem 'richtigen' Zertifikat, alles andere ist Murks. Die Kosten dafür und der Aufwand für die Einrichtung sind da erst einmal nebensächlich.
+1
Wobei: Die Einrichtung eines Zertifikats auf dem Server ist eine Sache weniger Minuten.
Guy hat geschrieben:Wobei man mit einem erbeutetem Passwort hier relativ wenig Dummheiten anstellen kann.
Hier vielleicht wenig, aber ich möchte nicht wissen, wer hier alles ein persönliches Universal-PW verwendet, das auch den Zugang zu relevanteren Diensten "schützt".

Ich bin unbedingt für Verschlüsselung. Wenn das Login geschützt wird, muss auch die gesamte session geschützt werden, sonst kann man es auch gleich lassen.
ZOE Intens Q210 2013-2018
ZOE ZE40 Limited R110 ab 2019
Ratgeber Elektroautos | ZOE-Blog
Anzeige

Re: https (SSL) Zugang zum Forum

menu
Guy
    Beiträge: 3591
    Registriert: Fr 26. Aug 2011, 14:52
    Danke erhalten: 48 Mal
Administrator

folder Di 5. Aug 2014, 14:15

Elektrolurch hat geschrieben:Die Einrichtung eines Zertifikats auf dem Server ist eine Sache weniger Minuten.
Ist ein Managed Server, von daher ist das Einrichten des Zertifikats überhaupt keine Arbeit für mich. Allerdings hängt da ja noch ein ganzer Rattenschwanz dran. Das Forum ist mittlerweile an so vielen Stellen modifiziert worden, dass es mich wundern würde, wenn nicht zahlreichen Änderungen notwendig wären, damit es auch verschlüsselt fehlerfrei läuft.
Elektrolurch hat geschrieben:wer hier alles ein persönliches Universal-PW verwendet
Dass das eine weniger gute Idee ist, dürfte sich ja mittlerweile herumgesprochen haben.

Re: https (SSL) Zugang zum Forum

menu
Benutzeravatar

folder Di 5. Aug 2014, 14:38

Guy hat geschrieben:Das Forum ist mittlerweile an so vielen Stellen modifiziert worden, dass es mich wundern würde, wenn nicht zahlreichen Änderungen notwendig wären, damit es auch verschlüsselt fehlerfrei läuft.
Also eigentlich... fällt mir gerade kein Grund ein, wieso nach Einrichtung des Zertifikats beim Aufruf des Forums über eine https-Verbindung irgendwas NICHT funktionieren sollte. Das hat doch mit der Programmierung gar nichts zu tun, es geht ja nur um den Datentransfer, und um dessen Verschlüsselung kümmern sich dann Browser und Server "ganz von selbst". :geek:
ZOE Intens Q210 2013-2018
ZOE ZE40 Limited R110 ab 2019
Ratgeber Elektroautos | ZOE-Blog

Re: https (SSL) Zugang zum Forum

menu
Guy
    Beiträge: 3591
    Registriert: Fr 26. Aug 2011, 14:52
    Danke erhalten: 48 Mal
Administrator

folder Di 5. Aug 2014, 16:16

So ganz von selbst leider auch nicht.

In einigen Erweiterungen stecken sicher noch harte Links auf http, was jedesmal eine unnötige Umleitung bedeuten würde, zudem meckert der Browser, wenn nicht alles verschlüsselt übertragen wird. Da kenne ich jetzt schon ein paar Ecken, bei denen ich nachbessern muss. Alles kein riesen Sache, gemacht werden muss es trotzdem.

Re: https (SSL) Zugang zum Forum

menu
Itzi
    Beiträge: 602
    Registriert: Di 19. Mär 2013, 18:21
    Wohnort: Oberösterreich
    Website

folder Di 5. Aug 2014, 22:01

Solche Dinge wie harte Links im Code sind immer ärgerlich - das dauert oft ewig bis die letzten zum Vorschein kommen.
Klingt ein wenig nach einem möglichen "nebenbei-Projekt". Man könnte SSL mal einrichten lassen und nach und nach diese Links finden. SSL-Verbindung sollten halt nur die anwählen die es sich drauf stehen. Dabei sollte jedem klar sein, dass das vielleicht nicht Priorität hat bei der Wartung/Pflege des Forums.
Erstellt mit 100% Ökostrom.
ZOE, Zero SR, Elektroroller & Automower. Model 3 vorsorglich reserviert.
Antwortenedit build arrow_drop_down

Zurück zu „GoingElectric Forum“

Gehe zu arrow_drop_down