SimpleEVSE WB mit WLAN

Alles rund ums Elektroauto-Laden / Ladeboxen / Ladegeräte

Re: SimpleEVSE WB mit WLAN

Beitragvon CurtRod » Fr 20. Apr 2018, 00:07

Dentec hat geschrieben:
@CurtRod
Bei mir klappt jetzt die Verbindung mit der SimpleEVSE WB, nachdem ich herausgefunden habe, dass man Modbus per 5xTaster beim Einschalten der SimpleEVSE erst aktivieren muss...

Wie kann ich am einfachsten das ModbusRegister 2001 auf 1 setzen, damit die Einstellung "Modbus dauerhaft an". aktiv ist ?
Ist das irgendwie über das Menü oder Setup vorgesehen ?

Hi Dentec,

das Register 2001 bleibt dauerhaft gesetzt, sobald ein Register >= 2000 geschrieben oder gelesen wird. Am einfachsten machst du das in SimpleEVSE-WiFi indem du auf der "EVSE Control" Seite die evse einmal aktivierst und deaktivierst. Dabei wird jeweils das Register 2005 geschrieben. Alternativ müsste es auch funktionieren, wenn du in der Settings Page die zusätzlichen Infos (Show Device Status) anklickst. Dabei werden auch Register > 2000 gelesen.

Dentec hat geschrieben:
Und noch etwas: Der RFID-Reader funktioniert bei mir nicht. Angeschlossen ist er wie beschrieben und am Arduino per Beispiel-Code habe ich ihn erfolgreich getestet. Es ist ein RC522. In welchem Menü kann ich die Funktion am besten testen ? (ich habe es im User-Menü versucht)

Hast du in den settings RFID aktiviert und den richtigen GPIO für den SS-Pin angegeben? Hier ist zu beachten, dass die "generic" GPIOs verwendet werden. Der Pin D8 am wemos d1 mini bzw. am nodemcu ist beispielsweise intern GPIO 15. Wenn du Pin D8 (wie ich es auf GitHub beschrieben habe) für den SPI verwendest, musst du GPIO15 in den settings auswählen.
Testen kannst du das tatsächlich am besten auf der User Seite. Da müsste sofort sowas ähnliches wie ein Pop-up (modal) aufgehen, wo die uid des gescannten Tags bereits vorausgefüllt ist. An dieser Stelle ein kleiner Hinweis: nach dem Speichern des Users bitte nochmal den User bearbeiten und prüfen ob die Gültigkeitsdauer korrekt hinterlegt wurde. Das funktioniert noch nicht immer aufs erste Mal.

Wenn es dann noch nicht klappt, melde dich gerne nochmal!

Grüße
Curt

Gesendet von meinem Aquaris X5 Plus mit Tapatalk
Entwickler von SimpleEVSE-WiFi
CurtRod
 
Beiträge: 66
Registriert: Di 12. Dez 2017, 08:28

Anzeige

Re: SimpleEVSE WB mit WLAN

Beitragvon umali » Fr 20. Apr 2018, 08:20

CurtRod hat geschrieben:
Hi Dentec,

das Register 2001 bleibt dauerhaft gesetzt, sobald ein Register >= 2000 geschrieben oder gelesen wird. Am einfachsten machst du das in SimpleEVSE-WiFi indem du auf der "EVSE Control" Seite die evse einmal aktivierst und deaktivierst. Dabei wird jeweils das Register 2005 geschrieben. Alternativ müsste es auch funktionieren, wenn du in der Settings Page die zusätzlichen Infos (Show Device Status) anklickst. Dabei werden auch Register > 2000 gelesen.

Hallo Curt,
Du schreibst bei jedem Click auf ACTIVATE auf reg. 2005? Ich denke, dass diese Idee nicht so gut ist, da der Entwickler meinte:
> We guess all reg with 1xxx could be written often and with 2xxx (EEPROM) not. Are we right?
yes

Kannst Du das ändern? Normalerweise reicht einmal auf der SETTING-Seite, die max. A zu ändern und zu speichern. Dann müsste reg.2000 neu geschrieben sein und Modbus bleibt dauerhaft aktiv.
Das könnte man mit in die manual auf github schreiben - am besten gleich die ganze Modbusaktivierungs-Prozedur (5x innerhalb 3s AN+GND verbinden (mittels temp. angeschlossenem Taster) und dann max. A auf der Settingsseite verstellen u. speichern)

Kannst Du bitte nochwas zu meiner Zähleridee sagen?

VG U x I
* Mitentwickler v. http://www.openWB.de - Die modulare OpenSource Wallbox Lösung mit Energiemanagment
* Entwickler v. "UxI toGo" ladeequipment/uxi-togo-die-neue-smarte-mobile-wb-diy-open-source-t32715.html
umali
 
Beiträge: 2094
Registriert: Mi 16. Nov 2016, 16:32

Re: SimpleEVSE WB mit WLAN

Beitragvon paxxi » Sa 21. Apr 2018, 09:45

CurtRod hat geschrieben:
....
Speicherplatz ist auch 4MB begrenzt. Der Sketch benötigt schon mal eine Partition mit 1mb, damit wären noch 3MB für SPIFFS übrig. die html-Dateien und das restliche krims krams sind derzeit knap 400kb, wobei ich das in naher Zukunft etwas einzudampfen versuche und auf die Sketch Partition auslagern möchte. Damit wären dann die 3mb nur noch mit config, log-daten und berechtigten RFID-Tags belegt.
...


Vergiss nicht, dass du nochmal Platz für's OTA-Update brauchst. ;)
paxxi
 
Beiträge: 47
Registriert: Do 29. Jun 2017, 10:25

Re: SimpleEVSE WB mit WLAN

Beitragvon CurtRod » Sa 21. Apr 2018, 11:14

Hallo zusammen,

hatte in den letzten Tage einiges um die Ohren, daher erst heute die Antworten

umali hat geschrieben:
Wir hatten doch über die Idee, nur 1 Phase zu messen und dann bei 2p bzw. 3p zu faktorieren, gesprochen.
Den SDM120 Modbus RTU 1p bekomme ich noch in die mobile WB integriert.
Wenn es bei Einstellungen nun einen neuen Schalter für 1-,2- oder 3-phasig gäbe, könnte damit der Faktor 1,2,3 hinterlegt werden.

Nutzen werden wir sicher Register 30013 active power (L1), was die Wirkleistung in Watt darstellt. Die Zählerfaktorierung wäre ein echter Zusatznutzen und man spart sich die teuren SDM630 3p-Zähler. Kleinere Abweichungen aus unterschiedlichen Phasenbelastungen kann man sicher ignorieren. Es geht ja um kWh-Schätzungen - hartes Abrechnen ist eh nicht angedacht.

Falls jemand einen 3-p-SDM630-Zähler nutzen möchte, müsste man den Schalter aber deaktivieren und reg. 30053 (total system power) nutzen können. Oder dann die Reg. 30013 + 30015 + 30017 addieren.

Das ist bereits notiert und wir sicherlich bald kommen. Sobald mein SDM-Zähler da ist, werde ich damit mal rumspielen. :)

umali hat geschrieben:
#update:
Ev. noch einfacher => unter Einstellungen:
* Auswahlfeld für SDM120(230) / SDM630 (spätere weitere mgl., da ja die Register je Zählertyp variieren), wo entweder Reg. 30013 (L1) oder Reg. 30053 (L1+L2+L3) ausgelesen werden
* aus obigem Auswahlfeld => Ermittlung und Anzeige, ob 1p oder 3p-Zähler vorhanden
* nur bei 1p-Zähler: ein optionales Feld "Faktorierung Zählerwirkleistung", um bei Vorhandensein eines 1p-Zählers für ein 2- oder 3p-EV hochskalieren zu können

So in etwa habe ich mir das auch vorgestellt. Die genauen Register werde ich mir dann nochmal anschauen, wenn ich den Zähler habe. Habe aber vor, das schon möglichst transparent und modular zu halten.

umali hat geschrieben:
Blöd wird es, wenn das EV wechselt (z.B. i3 60Ah mit 1p und danach ein e-Golf mit 2p). Bei diesen Szenarien mit variablem Fahrzeug würde ich den 3p-Zähler als "must have" empfehlen. Damit hätte man alle Sorgen los.

Das sehe ich auch so. Das ist einfach anders nicht machbar. Wenn man wechselnde EVs mit unterschiedlichen Ladern laden will, muss man eben einen 3p-Zähler verwenden.

umali hat geschrieben:
Das und die km-Anzeige unter der kWh-Anzeige wären meine vordringlichsten Wünsche, aber ich hab' hier eh wenig zu melden ;-).

Schau doch mal auf Github meine Projekte an. Da habe ich schon einige Ideen gesammelt, die ich nach und nach in Angriff nehmen möchte: https://github.com/CurtRod/SimpleEVSE-WiFi/projects
Da kannst du auch ein bisschen verfolgen, woran ich gerade arbeite und was die nächsten geplanten Features sind.

umali hat geschrieben:
In neueren EVSE-Varianten könnte ev. ein größerer ACDC kommen, weil dort Anschlüsse für Addons vorgesehen sind. Der Entwickler sprach von 3W statt 1W. Das ist aber noch nicht spruchreif, würde aber die ganze Stromversorgung entspannen.

Mit einem 3W ACDC wäre natürlich das Stromversorgungsproblem etwas entspannter, das stimmt. Wir werden sehen, wie es dann in der finalen Version aussieht. Viel teurer soll die ja auch nicht werden, laut seiner Homepage...

umali hat geschrieben:
Du schreibst bei jedem Click auf ACTIVATE auf reg. 2005? Ich denke, dass diese Idee nicht so gut ist, da der Entwickler meinte:
> We guess all reg with 1xxx could be written often and with 2xxx (EEPROM) not. Are we right?
yes

Ja, ich schreibe jedes mal das Register 2005 beim aktivieren/deaktivieren. Die EVSE WB ist im Normalfall immer im Zustand "deaktiviert". Also wenn man ein EV ansteckt, passiert nichts. Bei einem Klick auf "activate", Druck auf den Taster oder Enstperrung über RFID wird im Register 2005 das bit 13 (disable after charge) gesetzt. Damit ist nach dem Ladevogang sichergesetellt, dass die EVSE wieder deaktiviert ist. Beim manuellen deaktivieren über das GUI wird das bit 14 (disable EVSE) gesetzt. So ist sichergesetllt, dass nur berechtigte Personen laden können. Desweiteren benötige ich die jeweiligen Trigger, um die Zeit- und Energiemessung zu starten bzw. zu beenden und dann einen Log-Eintrag zu schreiben. Ein "hübscherer" Prozess ist mir bislange nicht eingefallen, bin aber gerne für Vorschläge offen.

umali hat geschrieben:
Kannst Du das ändern?

Anders ist die Ansteuerung aus meiner Sicht nicht möglich. Wenn man sich die Dokumentation der Register der EVSE WB genauer durchliest, entsteht meiner Meinung nach aber der Eindruck, dass das Register 2005 für genau diese Art der Steuerung vorgesehen ist. Was bedeutet denn "not often"? Wenn es sich um einen normales EEPROM auf Basis von SLC handelt, wie es oben angedeutet wurde, wären ~100.000 Schreibzyklen als realistischer Wert anzusetzen, das wären dann 100.000 Ladevorgänge. Man könnte somit dann über 149 Jahre zweimal pro Tag laden, ohne dass das EEPROM durch die Schreibvorgänge zerstört würde. Da die Speicherzellen aber auch durch Zeit "altern" weiß keiner, ob diese in 20 oder 30 Jahren noch lesbar sind. An dieser Stelle wäre es interessant, was dieser Entwickler für ein EEPROM, bzw. welche Art von Speicherzellen für das EEPROM verwendet.

umali hat geschrieben:
Normalerweise reicht einmal auf der SETTING-Seite, die max. A zu ändern und zu speichern. Dann müsste reg.2000 neu geschrieben sein und Modbus bleibt dauerhaft aktiv.
Das könnte man mit in die manual auf github schreiben - am besten gleich die ganze Modbusaktivierungs-Prozedur (5x innerhalb 3s AN+GND verbinden (mittels temp. angeschlossenem Taster) und dann max. A auf der Settingsseite verstellen u. speichern)

Das reicht nicht aus. der maximale Ladestrom, der in den Settings definiert wird, beeinflusst keine Register auf der EVSE. Dieser Wert wird aktuell nur für die Range des Sliders auf der EVSE Control Seite verwendet, wo man den aktuellen Ladestrom ändern kann. Aber die Idee ist gut und ich hab mir mal notiert, dass man das überdenken könnte, ob man nicht den Wert für den maximalen Ladestrom in das Register 2007 schreiben sollte. Damit wäre man dann noch ein Stück unabhängiger. Das sollte man aber nur bei Wallboxen mit angeschlagenem Kabel machen. Wenn man eine Wallbox mit Buchse hat, wo jeder sein eigenes Kabel mitbringt und jemand ein EV laden möchte, das 32A laden kann, die Wallbox auch mit 32A abgesichert ist, aber das mitgebrachte Kabel nur für 20A ausgelegt ist, wäre das nicht sinnvoll.

Grüße
Curt
Entwickler von SimpleEVSE-WiFi
CurtRod
 
Beiträge: 66
Registriert: Di 12. Dez 2017, 08:28

Re: SimpleEVSE WB mit WLAN

Beitragvon CurtRod » Sa 21. Apr 2018, 11:15

paxxi hat geschrieben:
Vergiss nicht, dass du nochmal Platz für's OTA-Update brauchst. ;)

Das ist natürlich auch noch ein Faktor, der den verfügbaren Speicherplatz begrenzt, ja! ;-)
Entwickler von SimpleEVSE-WiFi
CurtRod
 
Beiträge: 66
Registriert: Di 12. Dez 2017, 08:28

Re: SimpleEVSE WB mit WLAN

Beitragvon umali » Sa 21. Apr 2018, 12:08

Hey Curt,

herzlichen Dank für Deine sehr umfangreichen und aussagekräftigen Antworten!
Ich stimme Dir in vielen Dingen zu und antworte nur auf verbliebene Punkte.

Wieviel das in der MCU integrierte EEPROM aushält, kann ich noch nicht sagen. Ev. gibt es sogar ein externes EEPROM, aber das ist sehr unwahrscheinlich.
Ich weiß nur, dass einen Microchip-MCU PIC16F1825 verwendet wird. Ich habe selbst schon mit dem Pickit3-programmer FW geflashed.

Klar halten die EEPROMs heutzutage etwas aus, aber ich war wegen der Antwort vom Entwickler beunruhigt.
Reg. 2005 scheint von der Beschreibung eigentlich dafür geeignet. Reg. 1000 nutzen wir für sehr häufige Stromvorgaben mit openWB.
Wenn das tatsächlich für Vielschreiberei herangezogen werden kann, hätte ich auch Reg.1000 oder noch besser Reg.1004 bit0 für ACTIVATE/DEACTIVATE genutzt. Beide 1xxx sind R/W und vom Entwickler lt. letzter Aussage für Vielschreiberei zugelassen.
Ich rede da nochmal mit dem EVSE-Entwickler. Das müssen wir vorher sauber wissen. Lass es zunächst bitte wie es ist.

Wegen der max. Kabelstrombelastbarkeit musst Du Dir keine Sorgen machen. Die wird bei einem Stecker/Buchse-Kabel durch beidseitige R_pp "hart" im Kabel definiert. Solange die EVSE den Erkennungsautomatismus an hat (Reg. 2007 = 0) liefert uns das an Reg.1003 die tatsächliche Strombelastbarkeit.

Jetzt kann aber noch der Fall bei mobiler WB auftreten, dass die Installation weniger Strom ab kann als das Kabel. Hierfür wäre Dein Wert auf der Einstellseite super, der dann einfach die Wertübergabe an Register 1000 "begrenzt". Sozusagen ohne Nutzung des EVSE-Begrenzungsregisters.

Sowie ich die "EVSE DIN" in der Hand halte, informiere ich Dich bezüglich des stärkeren ACDC. Ev. ist es noch nicht im Prototyp drin, aber der Entwickler hatte schon 3W auf dem Schirm. Mal sehen, ob er es jetzt schon realisiert hat.

Könntest Du ev. ALLE wichtigen Register auf der Einstellseite anzeigen? Gerade der 2003 ist wegen späterer Modbus-ID sehr wichtig. Also so hier:
1000...1006
2000...2009 Die danach sind nicht so wichtig (nur bei Button-Nutzung).

Sind Dir commits auf github lieber? Ich freunde mich gerade damit an.
Danke hierfür - sehr professionell!
https://github.com/CurtRod/SimpleEVSE-WiFi/projects

VG U x I
* Mitentwickler v. http://www.openWB.de - Die modulare OpenSource Wallbox Lösung mit Energiemanagment
* Entwickler v. "UxI toGo" ladeequipment/uxi-togo-die-neue-smarte-mobile-wb-diy-open-source-t32715.html
umali
 
Beiträge: 2094
Registriert: Mi 16. Nov 2016, 16:32

Re: SimpleEVSE WB mit WLAN

Beitragvon CurtRod » So 22. Apr 2018, 15:52

Hi U x I

umali hat geschrieben:
Klar halten die EEPROMs heutzutage etwas aus, aber ich war wegen der Antwort vom Entwickler beunruhigt.
Reg. 2005 scheint von der Beschreibung eigentlich dafür geeignet. Reg. 1000 nutzen wir für sehr häufige Stromvorgaben mit openWB.
Wenn das tatsächlich für Vielschreiberei herangezogen werden kann, hätte ich auch Reg.1000 oder noch besser Reg.1004 bit0 für ACTIVATE/DEACTIVATE genutzt. Beide 1xxx sind R/W und vom Entwickler lt. letzter Aussage für Vielschreiberei zugelassen.
Ich rede da nochmal mit dem EVSE-Entwickler. Das müssen wir vorher sauber wissen. Lass es zunächst bitte wie es ist.

Schade, dass das nirgendwo dokumentiert ist, dass die Register 2000 keine "häufigen" Schreibvorgänge aushalten. Trotzdem wäre es interessant, was dem Entwickler dazu noch einfällt. Wäre ziemlich hilfreich, wenn du da mal nachhaken könntest! Das Problem bei der Nutzung von Register 1006 ist, dass nach dem Ladevorgang die EVSE WB nicht automatisch wieder deaktiviert wird. Da ist die Nutzung des Register 2005 / bit13 einfach genau das richtige. Sollte das wirklich ein Problem sein, das Register 2005 so "oft" zu schreiben, würde ich mir halt einen Workaround ausdenken müssen...

umali hat geschrieben:
Wegen der max. Kabelstrombelastbarkeit musst Du Dir keine Sorgen machen. Die wird bei einem Stecker/Buchse-Kabel durch beidseitige R_pp "hart" im Kabel definiert. Solange die EVSE den Erkennungsautomatismus an hat (Reg. 2007 = 0) liefert uns das an Reg.1003 die tatsächliche Strombelastbarkeit.

Das ist mir soweit klar. Mir ging es um den Settings-Parameter "Max. Current" in SimpleEVSE-WiFi. Wenn man diesen ändert, werden keine Register in der EVSE WB geändert. Dieser Parameter definiert lediglich die Range des Sliders, um auf der EVSE-Control Seite den Ladestrom anzupassen.

umali hat geschrieben:
Jetzt kann aber noch der Fall bei mobiler WB auftreten, dass die Installation weniger Strom ab kann als das Kabel. Hierfür wäre Dein Wert auf der Einstellseite super, der dann einfach die Wertübergabe an Register 1000 "begrenzt". Sozusagen ohne Nutzung des EVSE-Begrenzungsregisters.

Genau so ist das ja momentan auch implementiert. Der Wert auf der Settings-Page ist nur für das Front-End ohne die Einstellungen auf der EVSE WB zu ändern.

umali hat geschrieben:
Sowie ich die "EVSE DIN" in der Hand halte, informiere ich Dich bezüglich des stärkeren ACDC. Ev. ist es noch nicht im Prototyp drin, aber der Entwickler hatte schon 3W auf dem Schirm. Mal sehen, ob er es jetzt schon realisiert hat.

Das wäre super, wenn du mir das mitteilen könntest, sobald du da genaueres weißt!

umali hat geschrieben:
Könntest Du ev. ALLE wichtigen Register auf der Einstellseite anzeigen? Gerade der 2003 ist wegen späterer Modbus-ID sehr wichtig. Also so hier:
1000...1006
2000...2009 Die danach sind nicht so wichtig (nur bei Button-Nutzung).

Auch das ist bereits im Backlog. (siehe Projekt 1.0.0 auf github). Bisher stand da nur als Feature, dass die Modbus Register über das GUI geschrieben werden können. Habe das mal präzisiert und die ausgabe aller Register mit aufgenommen. Ehrlichgesagt, war ich da etwas schreibfaul, gleich alle Register im GUI auszugeben! ;-)

umali hat geschrieben:
Sind Dir commits auf github lieber? Ich freunde mich gerade damit an.

Das ist mir eigentlich relativ egal! ;-) Ich arbeite ganz gerne mit dem Project-Tool auf github, aber ich schreib mir da meine Notes auch selbst! ;-)

Grüße
Curt
Entwickler von SimpleEVSE-WiFi
CurtRod
 
Beiträge: 66
Registriert: Di 12. Dez 2017, 08:28

Re: SimpleEVSE WB mit WLAN

Beitragvon umali » So 22. Apr 2018, 22:40

Hey CurtRod,

CurtRod hat geschrieben:
Schade, dass das nirgendwo dokumentiert ist, dass die Register 2000 keine "häufigen" Schreibvorgänge aushalten. Trotzdem wäre es interessant, was dem Entwickler dazu noch einfällt. Wäre ziemlich hilfreich, wenn du da mal nachhaken könntest! Das Problem bei der Nutzung von Register 1006 ist, dass nach dem Ladevorgang die EVSE WB nicht automatisch wieder deaktiviert wird. Da ist die Nutzung des Register 2005 / bit13 einfach genau das richtige. Sollte das wirklich ein Problem sein, das Register 2005 so "oft" zu schreiben, würde ich mir halt einen Workaround ausdenken müssen...

Ich habe es soeben nochmal angefragt. Antwort dauert meist etwas.

Du meinst aber sicher Reg. 1004 - nicht 1006, da nur 1000 u. 1004 R/W sind.
Ja bei Reg. 1004 wird nach Ladeende nur das Laden gestoppt - nicht die EVSE deaktiviert.

Ich frage mich noch, warum Deaktivieren unbedingt nötig sein soll - reicht denn nicht die Ladung zu stoppen? Der Lader im EV sagt Stop und der Schütz schaltet ab. Das passiert auch bei allen writes auf reg. 1000 mit Wert <6 (A).

CurtRod hat geschrieben:
Das ist mir soweit klar. Mir ging es um den Settings-Parameter "Max. Current" in SimpleEVSE-WiFi. Wenn man diesen ändert, werden keine Register in der EVSE WB geändert. Dieser Parameter definiert lediglich die Range des Sliders, um auf der EVSE-Control Seite den Ladestrom anzupassen.

Ah ok - verstehe.

CurtRod hat geschrieben:
Genau so ist das ja momentan auch implementiert. Der Wert auf der Settings-Page ist nur für das Front-End ohne die Einstellungen auf der EVSE WB zu ändern.

sehr gut

CurtRod hat geschrieben:
Auch das ist bereits im Backlog. (siehe Projekt 1.0.0 auf github). Bisher stand da nur als Feature, dass die Modbus Register über das GUI geschrieben werden können. Habe das mal präzisiert und die ausgabe aller Register mit aufgenommen. Ehrlichgesagt, war ich da etwas schreibfaul, gleich alle Register im GUI auszugeben! ;-)

na bestens.
Sag' mal - bei 1.0.0 willst Du mit ESP32 arbeiten?
Wenn Du das so planst, wäre der Wemos 32 wieder eine sehr kompakte Plarine, wenn auch leicht größer als der Wemos Mini D1.


CurtRod hat geschrieben:
Ich arbeite ganz gerne mit dem Project-Tool auf github, aber ich schreib mir da meine Notes auch selbst! ;-)

Ja das ist gut. Jeder sieht gleich, was Du auf dem Schirm hast. Sozusagen öffentliche Agenta.

Gute Woche!
VG U x I
* Mitentwickler v. http://www.openWB.de - Die modulare OpenSource Wallbox Lösung mit Energiemanagment
* Entwickler v. "UxI toGo" ladeequipment/uxi-togo-die-neue-smarte-mobile-wb-diy-open-source-t32715.html
umali
 
Beiträge: 2094
Registriert: Mi 16. Nov 2016, 16:32

Re: SimpleEVSE WB mit WLAN

Beitragvon CurtRod » Mo 23. Apr 2018, 18:43

umali hat geschrieben:
Du meinst aber sicher Reg. 1004 - nicht 1006, da nur 1000 u. 1004 R/W sind.
Ja bei Reg. 1004 wird nach Ladeende nur das Laden gestoppt - nicht aber die EVSE deaktiviert.

Ich frage mich noch, warum Deaktivieren unbedingt nötig sein soll - reicht denn nicht die Ladung zu stoppen? Der Lader im EV sagt Stop und der Schütz schaltet ab. Das passiert auch bei allen writes auf reg. 1000 mit Wert <6 (A).

Ja genau, ich meinte Reg 1004! ;-) Der Hintergrund des deaktivierens ist eigentlich der, dass die Wallbox keinen Ladevorgang startet, wenn keine Berechtigte Person die Freigabe gibt. Also wenn man seine Box vor der Haustüre aufgehängt hat und man beispielsweise 3 Wochen im Urlaub ist, dass nicht jeder einfach sein EV ansteckt und auf meine Stromrechnung lädt.
Wie gesagt, sollte sich der Entwickler dazu äußern, dass die Schreibzyklen auf die 2000er Register wirklich so kritisch sind, muss ich mir eben einen Workaround überlegen! Zum Aktivieren und Deaktivieren das Register 2005 zu verwenden, ist eben der einfachste Weg das zu realisieren.
Man könnte vielleichtauch bei der Erkennung, wenn das EV den Ladevorgang beendet hat, das Register 1000 auf <6 ("deaktiviert" - wenn ein EV den Ladevorgang anfordert, passiert erst mal nichts?!) setzen und sobald die Freigabe über RFID oder das WebUI erfolgt wieder auf >6 ("aktiviert", EVSE lässt Ladevorgang wieder zu) setzen, wenn ich dich richtig verstanden habe!? Wenn das Register 1000 < 6 ist, schaltet die EVSE das Schütz also nicht durch, oder? Müsste ich mal testen...

umali hat geschrieben:
Sag' mal - bei 1.0.0 willst Du mit ESP32 arbeiten?
Wenn Du das so planst, wäre der Wemos 32 wieder eine sehr kompakte Plarine, wenn auch leicht größer als der Wemos Mini D1.

Geplant ist der zusätzliche Support, sodass SimpleEVSE-WiFi sowohl auf dem ESP8266 als auch auf dem ESP32 lauffähig ist. Die Schwierigkeit dabei ist, dass es teilweise auch unterschiedliche Bibliotheken für ESP32 und ESP8266 gibt. Das ist allerdings bisher nur im Backlog und noch nicht konkret für Version 1.0.0 als ToDo eingeplant. Die Backlog-Items sind Features, die ich irgendwann mal in Angriff nehmen möchte, wenn andere Funktionen getestet und etwas robuster sind. Wann und wie das dann konkret implementiert wird, muss man dann schauen.

Grüße
Curt
Entwickler von SimpleEVSE-WiFi
CurtRod
 
Beiträge: 66
Registriert: Di 12. Dez 2017, 08:28

Re: SimpleEVSE WB mit WLAN

Beitragvon umali » Mo 23. Apr 2018, 21:38

CurtRod hat geschrieben:
Ja genau, ich meinte Reg 1004! ;-) Der Hintergrund des deaktivierens ist eigentlich der, dass die Wallbox keinen Ladevorgang startet, wenn keine Berechtigte Person die Freigabe gibt. Also wenn man seine Box vor der Haustüre aufgehängt hat und man beispielsweise 3 Wochen im Urlaub ist, dass nicht jeder einfach sein EV ansteckt und auf meine Stromrechnung lädt.
Wie gesagt, sollte sich der Entwickler dazu äußern, dass die Schreibzyklen auf die 2000er Register wirklich so kritisch sind, muss ich mir eben einen Workaround überlegen! Zum Aktivieren und Deaktivieren das Register 2005 zu verwenden, ist eben der einfachste Weg das zu realisieren.

Das verstehe ich. Lass uns mal abwarten, was der Entwickler zur Schreibzyklenzahl der 1xxx und 2xxx Register sagt.
CurtRod hat geschrieben:
Man könnte vielleichtauch bei der Erkennung, wenn das EV den Ladevorgang beendet hat, das Register 1000 auf <6 ("deaktiviert" - wenn ein EV den Ladevorgang anfordert, passiert erst mal nichts?!) setzen und sobald die Freigabe über RFID oder das WebUI erfolgt wieder auf >6 ("aktiviert", EVSE lässt Ladevorgang wieder zu) setzen, wenn ich dich richtig verstanden habe!? Wenn das Register 1000 < 6 ist, schaltet die EVSE das Schütz also nicht durch, oder? Müsste ich mal testen...

Könnte klappen. Alternativ die Ladung mit Reg. 1004 und bit 0 "hart" abschalten. Das wäre dann ähnlich dem jetzigen Reg. 2005 und ev. einfacher.
Bei Reg. 1000 hätte man nämlich ggf. ein EV, was den Standard von min I = 6A nicht einhält (gewollt oder ungewollt) und schon lädt die Kiste wieder.
CurtRod hat geschrieben:
Geplant ist der zusätzliche Support, sodass SimpleEVSE-WiFi sowohl auf dem ESP8266 als auch auf dem ESP32 lauffähig ist. Die Schwierigkeit dabei ist, dass es teilweise auch unterschiedliche Bibliotheken für ESP32 und ESP8266 gibt. Das ist allerdings bisher nur im Backlog und noch nicht konkret für Version 1.0.0 als ToDo eingeplant. Die Backlog-Items sind Features, die ich irgendwann mal in Angriff nehmen möchte, wenn andere Funktionen getestet und etwas robuster sind. Wann und wie das dann konkret implementiert wird, muss man dann schauen.

OK verstehe.
Solange es der kleine ESP8266 tut, würde ich an Deiner Stelle bei dem bleiben. Ich muss auch erstmal die Stromversorgung der neuen EVSE DIN checken. Es wäre schon gut, wenn wir so einen kleinen ESP mitversorgen könnten. Das spart ein ganzes Netzteil und Kabelsalat.

VG U x I
* Mitentwickler v. http://www.openWB.de - Die modulare OpenSource Wallbox Lösung mit Energiemanagment
* Entwickler v. "UxI toGo" ladeequipment/uxi-togo-die-neue-smarte-mobile-wb-diy-open-source-t32715.html
umali
 
Beiträge: 2094
Registriert: Mi 16. Nov 2016, 16:32

Anzeige

VorherigeNächste

Zurück zu Ladeequipment

 
  • Ähnliche Themen
    Antworten
    Zugriffe
    Letzter Beitrag
  • Ähnliche Artikel im Blog

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 5 Gäste