Phoenix Contact EV Charge Controller + Modbus

Alles rund ums Elektroauto-Laden / Ladeboxen / Ladegeräte

Re: Phoenix Contact EV Charge Controller + Modbus

Beitragvon TimoS. » Di 24. Okt 2017, 22:58

Hallo zusammen,
bin momentan in der Vorbereitung den Phoenix Controller in iobroker einzubinden. Bin erst am Anfang was Modbus angeht und komme gerade nicht weiter was die Adressen angeht:

Im Modbus Adapter sieht das so aus:
Bildschirmfoto 2017-10-24 um 22.43.31.png
Allgemeine Einstellungen IP etc.

IP-Adresse ist klar, Port 502 ist klar aber Adresse 180? Und all die anderen Einstellmöglichkeiten?

Dann gehts weiter. Ich hätte zunächst gern mal "Eingestellter Ladestrom (PWM-Signal)" (Adresse 300) und Ladevorgang ermöglichen (Adresse 400)

Was muss ich hier auswählen? Die Adressen müssten doch 6-stellig sein oder nicht?
Bildschirmfoto 2017-10-24 um 22.44.11.png
Adressen und Typ eingeben


Ist wahrscheinlich einfacher als ich gerade denke...
Vielleicht könnt ihr mich mal in die richtige Richtung schupsen.

Grüße
Timo
VW e-up! seit Juli 2014; PV-Anlage mit 10kWp seit Juni 2013; Tesla Model ☰ reserviert
Benutzeravatar
TimoS.
 
Beiträge: 929
Registriert: Fr 18. Apr 2014, 19:33

Anzeige

Re: Phoenix Contact EV Charge Controller + Modbus

Beitragvon Mittelhesse » Di 24. Okt 2017, 23:04

Als Geräte ID gibst du 180 ein, auf der vorherigen Seite habe ich einen Link gepostet, wo der Typ aufgeführt ist.
LG Stefan

Renault ZOE Q210 intens schwarz seit Juni 2015. Upgrade auf Z.E. 40 Batterie am 07.03.18 bei 114.019km.

Model 3 reserviert am 02.04.16
Benutzeravatar
Mittelhesse
 
Beiträge: 1086
Registriert: So 21. Jun 2015, 12:14
Wohnort: Biskirchen

Re: Phoenix Contact EV Charge Controller + Modbus

Beitragvon TimoS. » Di 24. Okt 2017, 23:22

Oh, super. Da hatte ich sogar schon drauf geklickt und dann doch übersehen. Danke
Und was hat es jetzt mit den 6-stelligen Adressen auf sich? Wie muss ich die angeben?

“holding register numbers span from 40001 to 465536”

Ist Adresse 300 dann = 40300
VW e-up! seit Juli 2014; PV-Anlage mit 10kWp seit Juni 2013; Tesla Model ☰ reserviert
Benutzeravatar
TimoS.
 
Beiträge: 929
Registriert: Fr 18. Apr 2014, 19:33

Re: Phoenix Contact EV Charge Controller + Modbus

Beitragvon Mittelhesse » Di 24. Okt 2017, 23:32

Die Adressen die im Link angegeben sind stimmen, die müsstest du auch so verwenden können, leider kenne ich deine Software nicht.
LG Stefan

Renault ZOE Q210 intens schwarz seit Juni 2015. Upgrade auf Z.E. 40 Batterie am 07.03.18 bei 114.019km.

Model 3 reserviert am 02.04.16
Benutzeravatar
Mittelhesse
 
Beiträge: 1086
Registriert: So 21. Jun 2015, 12:14
Wohnort: Biskirchen

Re: Phoenix Contact EV Charge Controller + Modbus

Beitragvon TimoS. » Di 24. Okt 2017, 23:34

Ich probiere es mal aus. Noch habe ich den Controller nicht, soll morgen ankommen. Jetzt kann ich mit einem Problem weniger schlafen. Vielen Dank schon mal.
VW e-up! seit Juli 2014; PV-Anlage mit 10kWp seit Juni 2013; Tesla Model ☰ reserviert
Benutzeravatar
TimoS.
 
Beiträge: 929
Registriert: Fr 18. Apr 2014, 19:33

Re: Phoenix Contact EV Charge Controller + Modbus

Beitragvon PavelCoast » Mi 25. Okt 2017, 17:28

Hallo,

zur Anregung hier mal ein Screenshot meiner config bei ioBroker.

René
Dateianhänge
iobroker_modbus_phoenix.jpg
Renault Zoe Life (Q210 Bj 03/2014, 52000 km)
7.28 kWp, Fronius Symo Hybrid, Fronius Battery, Laden mit PV Überschuss
[url]e-stammtisch-mv.blogspot.de[/url]
PavelCoast
 
Beiträge: 109
Registriert: Di 24. Jun 2014, 21:48
Wohnort: bei Stralsund

Re: Phoenix Contact EV Charge Controller + Modbus

Beitragvon TimoS. » Mi 25. Okt 2017, 23:41

Vielen Dank. Das sieht gut aus. Heute war nich nichts in der Post. :(
VW e-up! seit Juli 2014; PV-Anlage mit 10kWp seit Juni 2013; Tesla Model ☰ reserviert
Benutzeravatar
TimoS.
 
Beiträge: 929
Registriert: Fr 18. Apr 2014, 19:33

Re: Phoenix Contact EV Charge Controller + Modbus

Beitragvon TimoS. » Fr 27. Okt 2017, 17:13

So, Controller ist da. Hat geklappt mit den einfachen Nummern. Grobe Regelung läuft.
Auto folgt schön den eingestellten Strömen zwischen 6-16A. Überlege noch wie ich es handhaben sollte, wenn kurzfristig die Sonne weg ist. Gibt es eine Möglichkeit die Ladung zu stoppen, ohne das das Schütz komplett abschaltet? Über Register 400 auf "false" stoppt alles. Werde wohl eine Verzögerung einbauen um zu verhindert, dass bei kurzfristig wechselnder Solarpower die Ladung ständig ein und aus geschaltet wird.
VW e-up! seit Juli 2014; PV-Anlage mit 10kWp seit Juni 2013; Tesla Model ☰ reserviert
Benutzeravatar
TimoS.
 
Beiträge: 929
Registriert: Fr 18. Apr 2014, 19:33

Re: Phoenix Contact EV Charge Controller + Modbus

Beitragvon TimoS. » Di 31. Okt 2017, 01:02

Habe es jetzt so geregelt, dass ich nach 5 min ununterbrochen unter Minimum abschalte und nach 1 min über Minimum einschalte. Das verhindert zu häufiges An und Aus im Übergangsbereich.

Ich komme auch an alle Daten außer an die im 200er Bereich. Funktioniert das bei irgendjemandem? Würde z.B gerne wissen, wenn ein Signal am Eingang EN anliegt. Modbus Adresse 200. Bekomme aber keine Verbindung.
VW e-up! seit Juli 2014; PV-Anlage mit 10kWp seit Juni 2013; Tesla Model ☰ reserviert
Benutzeravatar
TimoS.
 
Beiträge: 929
Registriert: Fr 18. Apr 2014, 19:33

Re: Phoenix Contact EV Charge Controller + Modbus

Beitragvon Mittelhesse » Di 31. Okt 2017, 02:54

TimoS. hat geschrieben:
Habe es jetzt so geregelt, dass ich nach 5 min ununterbrochen unter Minimum abschalte und nach 1 min über Minimum einschalte. Das verhindert zu häufiges An und Aus im Übergangsbereich.

Ich komme auch an alle Daten außer an die im 200er Bereich. Funktioniert das bei irgendjemandem? Würde z.B gerne wissen, wenn ein Signal am Eingang EN anliegt. Modbus Adresse 200. Bekomme aber keine Verbindung.


schau mal welche Firmware dein Controller hat

https://www.goingelectric.de/forum/ladeequipment/phoenix-contact-ev-charge-controller-modbus-t13270-30.html#p511795
LG Stefan

Renault ZOE Q210 intens schwarz seit Juni 2015. Upgrade auf Z.E. 40 Batterie am 07.03.18 bei 114.019km.

Model 3 reserviert am 02.04.16
Benutzeravatar
Mittelhesse
 
Beiträge: 1086
Registriert: So 21. Jun 2015, 12:14
Wohnort: Biskirchen

Anzeige

VorherigeNächste

Zurück zu Ladeequipment

 
  • Ähnliche Themen
    Antworten
    Zugriffe
    Letzter Beitrag
  • Ähnliche Artikel im Blog

Wer ist online?

Mitglieder in diesem Forum: flor_tim und 10 Gäste