CaniOn Verbindungsprobleme

Re: CaniOn Verbindungsprobleme

Beitragvon Mei » Do 7. Dez 2017, 06:46

iOnier hat geschrieben:
.. Weiß nicht, was der App-Entwickler dafür kann bzw. wie er das ändern sollte.


z.B.. nicht davon ausgehen, dass man über BT ein 0,3Mbit Verbindung dauhaft stabil bekommt ohne das jemals ein Paket verloren geht. Es fehlt ja nur das erneute senden von "STM", dann kommen wieder Daten.
Das würde auch das Problem des neu koppeln einiger User lösen.
Das Kind ist aber schon in den Brunnen gefallen, wenn die Abrechnung der Ah auf die 100 Frames angewiesen ist. Jetzt muss man vermutlich ziemlich umfangreiche Änderungen machen um eine neue Zeitbasis zu implementieren.
Man könnte auch einfach die Frames zählen und die Ah per Faktor korrigieren. z.B: 89/100*Ah.

....
Hast Du eigentlich dies hier schon gelesen? Ich zitiere mal:
ADD hat geschrieben:
1. Der Adapter hängt sich teilweise auf wegen zu vieler Frames pro Sekunde. Entwickler Markus hat den Tipp gegeben, in den CaniOn-Settings "Acc Pedal History" und "Cockpit" zu deaktivieren. Dann sinkt die Framerate von etwa 420fps auf 290fps und zumindest mein Adapter lief wieder stabil.


Klar hab ich das schon gemacht.
Ohne das läufst selbst das S3mini nicht stabil.
Aber der Adapter hängt sich nicht auf, sondern es kommt "BUFFER FULL". Das würde sich mit "STM" lösen lassen. Siehe oben.

2. Einige Geräte mit Android 6 haben offensichtlich ein Problem mit Bluetooth. Z.B.: Huawei P8 Lite funktioniert nicht. Dagegen lief P9 Lite lief über zwei Stunden ( mit 290fps) , länger habe ich da allerdings nicht getestet. Am besten scheint es bei Geräten mit Android 5.1 zu funktionieren.


Hängt doch alles mit dem BUFFER FULL zusammen.

Hardware tauschen bis alles geht ist keine Lösung.

PS: ganz kostenlos ist die App nicht immer.
Jemand der sich dafür extra ein OBDLink kauft, der hat auch Kosten.

Die Bewertungen im Playstore und der Thread hier, den ich nicht angefangen habe, zeigen doch dass die Verbindung eben nicht stabil ist.
GTE 10/17 [PHEV]
iOn 09/16 [BEV]
3L 03/03 [TDI]
Mei
 
Beiträge: 1671
Registriert: Mo 18. Nov 2013, 13:57

Anzeige

Re: CaniOn Verbindungsprobleme

Beitragvon Heavendenied » Do 7. Dez 2017, 09:52

Du bist echt ein Scherzkeks... Was hat denn der Entwickler von CanIon davon, dass du Geld für den Dongle ausgibst?
Fakt ist, er stellt die App kostenlos zur Verfügung und hat dennoch bisher immer sehr vorbildlich bei der Fehlersuche unterstützt.
Und du bist der Meinung du musst ihn hier dafür schlecht machen und ihn mehr oder minder als zu blöd darstellen so einen kleinen Fehler zu beseitigen, den du als Top Programmierer ja ohnehin nie gemacht hättest... Sorry, aber sowas ist einfach vollkommen daneben!

Schau dir doch einfach mal EVBatMon an. Das kostet von vorneherein Geld, da kannst du dann auch Ansprüche an die Entwickler stellen. Ob die das dann beheben (können) ist natürlich auch wieder was anderes.

Und doch, Hardware tauschen bis alles geht ist auch eine Lösung, auch wenn sie dir nicht gefällt.

Und noch ein Hinweis:
Die meisten (mich inklusive) nutzen eben für CanIon einfach ein Smartphone/Tablet für CanIon, das fest im Auto verbleibt. Ist auch deutlich komfortabler, als das Smartphone immer extra aus der Tasche zu holen. Somit kann es einem auch vollkommen egal sein, wenn es ein "total veraltetes" Gerät ist. Man muss ja sonst nix mit machen.
Gruß,
Jürgen
(Citroen C-Zero, Vectrix VX-1 Li+)
Heavendenied
 
Beiträge: 1076
Registriert: Do 21. Nov 2013, 13:16

Re: CaniOn Verbindungsprobleme

Beitragvon drilling » Do 7. Dez 2017, 10:34

Mei hat geschrieben:
PS: ganz kostenlos ist die App nicht immer.
Jemand der sich dafür extra ein OBDLink kauft, der hat auch Kosten.


Ja, und man muß tatsächlich auch erst 8000 bis 18000 Euro für einen Drilling ausgeben. :o :roll:
Benutzeravatar
drilling
 
Beiträge: 3823
Registriert: Mo 18. Apr 2016, 21:59

Re: CaniOn Verbindungsprobleme

Beitragvon Mei » Do 7. Dez 2017, 22:38

Heavendenied hat geschrieben:
..... den du als Top Programmierer ....


Ne,
ich bin Top Hardwareentwickler.
Wir bauen Hardware im Terabit Übertragungsbereich.

Aber du hast Recht.
Wenn ich sehe was VW da seit Jahren für einen Mist mit dem Carnet veranstaltet, da ist CaniOn super. Bis auf essentielles, die Verbindung, die nicht stabil ist.
GTE 10/17 [PHEV]
iOn 09/16 [BEV]
3L 03/03 [TDI]
Mei
 
Beiträge: 1671
Registriert: Mo 18. Nov 2013, 13:57

Re: CaniOn Verbindungsprobleme

Beitragvon me68 » Do 7. Dez 2017, 23:30

Hallo Mei!

Ein paar (hoffentlich richtige) Zahlen:
caniOn nutzt das Filter-Kommando STFAP, um die 1.200fps am Can-Bus des Autos auf 420fps bzw. 300fps für die Übertragung auf das Android-Gerät zu reduzieren. Ein Frame kann entweder 19 oder 17 Byte haben (die PIDs 210 & 418 sind 17 Byte lang, alle anderen 19 Byte). Nehmen wir der Einfachheit halber an, alle Frames haben 19 Byte. Dann macht das im Höchstfall 420fps x 19Byte x 8Bit = 63.840Bit/s aus - netto - Protokolloverhead angenommen 10% - also rund 68kBit/s.

Bluetooth ab Version 3.0 hat eine (theoretische) Bandbreite von 3MBit/s (siehe http://www.itwissen.info/Bluetooth-Standard-Bluetooth-standard.html). Die meisten Android-Geräte haben ein Bluetooth 4.0 Interface. Ich denke das sollte ausreichen, selbst wenn von den theoretischen 3MBit/s nur 10% praktisch genutzt werden könnten, wären das noch 300kBit/s und grob 4 x soviel, wie caniOn im Höchstfall braucht.

Nochetwas: Der Ah-Wert wird nicht dauernd am Can-Bus gesendet. Der wird beim Start von caniOn per Can-Bus-Befehl abgefragt - hat nichts mit der sonst üblichen Datenverwertung zu tun.

Noch zwei Tipps:
Ein Problem könnten Interferenzen mit WLAN sein. Versuch es bitte mal mit abgeschaltetem WLAN.
Und - selbstredend - sollte caniOn die einzige Bluetooh-App sein - auch keine Kopplung mit der Freisprecheinrichtung.

Und nochmal: wenn keine Daten mehr übertragen werden, werden nochmal alle Can-Bus-Befehle gesendet - inklusive dem STM.

Das Referenzgerät ist ein Nexus7 2012 WiFi mit Android 5.1.1.


Martin
Bild

... unterwegs mit einem Citroen C-Zero, Bj. 8/2012
... unsere Vereinsseite: facebook.com/emobility.at
me68
 
Beiträge: 366
Registriert: So 5. Mai 2013, 11:54
Wohnort: Burgenland/Österreich

Re: CaniOn Verbindungsprobleme

Beitragvon Mei » Fr 8. Dez 2017, 00:06

Im OBDlink LX ist ein B33LT BT Modul drin.
LinkThroughput max 300K bps.

Mit Wireshark kann man sehen, dass 33 Byte pro Frame über das BT gehn. Das ist nur die Payload.

Es geht um das BUFFER FULL was der Elm327 eben sendet. Da ist es eben zuviel alles neu zu senden sofern die BT Verbindung noch steht. Da reicht ein STM, dann geht es weiter.
GTE 10/17 [PHEV]
iOn 09/16 [BEV]
3L 03/03 [TDI]
Mei
 
Beiträge: 1671
Registriert: Mo 18. Nov 2013, 13:57

Re: CaniOn Verbindungsprobleme

Beitragvon Mei » Mi 13. Dez 2017, 20:52

Hallo me68,

lange nix mehr gehört.
Arbeitest Du an dem "BUFFER FULL" Problem?
bzw. wird es in die App eingebaut?

Grüße
GTE 10/17 [PHEV]
iOn 09/16 [BEV]
3L 03/03 [TDI]
Mei
 
Beiträge: 1671
Registriert: Mo 18. Nov 2013, 13:57

Re: CaniOn Verbindungsprobleme

Beitragvon flechtlicht » Mi 13. Dez 2017, 22:09

Ich sehe in dem ganzen mehr ein menschliches denn ein technisches Problem. CaniOn ist mit viel Arbeit und Liebe verwirklicht und uns allen zum freien Gebrauch geschenkt worden. Wer's besser kann soll sich selber was programmieren, wen s ärgert der kann CaniOn auch bleiben lassen und gut ist.
Hier dem Entwickler auf die Pelle zu rücken und frech Nachbesserungen einzufordern und ihm auch noch den Kauf des Dongles verbrähmt anzulasten lässt sich nur noch mit Fremdschämen und Wilhelm Busch beantworten. " Höflichkeit ist eine Zier, doch leichter lebt sich's ohne ihr".

Freundliche Zusammenarbeit sieht anders aus. Freundlichkeit tut durch und durch gut und wärmt das Herz aller Beteiligten. Sie entwächst übrigens der Dankbarkeit.
S☀️nne tanken - Si☀️n fahren
~~~~S☀️mmer 2019~~~~~
Benutzeravatar
flechtlicht
 
Beiträge: 512
Registriert: Di 2. Aug 2016, 18:58

Re: CaniOn Verbindungsprobleme

Beitragvon Mei » Mi 13. Dez 2017, 22:22

@flechtlicht

deinen linken Scheiss kannste dir behalten. Blümchen und Bienchen machen keine APP :D

Hier reden echte Entwickler miteinander.

Da geht es halt auch mal Hart zur Sache.

Mit "LOVE" und ..... kann man halt keinen Preis gewinnen :D

Wir als Entwickler wollen die Welt verbessern.

Ja

Make Love

Make BUFFER leer :D
GTE 10/17 [PHEV]
iOn 09/16 [BEV]
3L 03/03 [TDI]
Mei
 
Beiträge: 1671
Registriert: Mo 18. Nov 2013, 13:57

Re: CaniOn Verbindungsprobleme

Beitragvon flechtlicht » Mi 13. Dez 2017, 22:27

Und ist der Ruf erst ruiniert, lebt sich's völlig ungeniert...
S☀️nne tanken - Si☀️n fahren
~~~~S☀️mmer 2019~~~~~
Benutzeravatar
flechtlicht
 
Beiträge: 512
Registriert: Di 2. Aug 2016, 18:58

Anzeige

VorherigeNächste

Zurück zu C-ZERO, i-MiEV, iON

 
  • Ähnliche Themen
    Antworten
    Zugriffe
    Letzter Beitrag
  • canion + tablet
    von west » Do 25. Feb 2016, 15:48
    3 Antworten
    964 Zugriffe
    Letzter Beitrag von west Neuester Beitrag
    Do 7. Apr 2016, 15:12
  • caniOn App: Wunschliste
    von Dr_Faust » Sa 27. Feb 2016, 14:10
    1 Antworten
    670 Zugriffe
    Letzter Beitrag von Elko Neuester Beitrag
    Di 1. Mär 2016, 13:16
  • Anschluss Canion
    von anco » Di 27. Sep 2016, 11:48
    0 Antworten
    0 Zugriffe
    Letzter Beitrag von Gast Neuester Beitrag
    Do 1. Jan 1970, 02:00
  • Anschluss Canion
    von anco » Di 27. Sep 2016, 11:50
    0 Antworten
    0 Zugriffe
    Letzter Beitrag von Gast Neuester Beitrag
    Do 1. Jan 1970, 02:00
  • Anschluss Canion
    von anco » Di 27. Sep 2016, 11:50
    5 Antworten
    670 Zugriffe
    Letzter Beitrag von Elko Neuester Beitrag
    Di 20. Dez 2016, 10:36
  • Ähnliche Artikel im Blog

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste