Renault ZOE: POI zum R-Link hinzufügen

Wechseln zu: Navigation, Suche

Zurück zu Renault ZOE: Howtos

R-link TomTom mit eigenen POI-Daten laden

Vorbereitung - POI's holen:
http://www.goingelectric.de/stromtankstellen/poi/
gewünschte Länder, Verbund, Ladestecker markieren
Dateiformat "OV2 TomTom" auswählen
und "POI herunterladen" und abspeichern (dabei merken wo !) ...
Tipp:
Mehrere *.ov2 erzeugen mit unterschiedlicher Filterung nach Ladeleistung u.s.w.
- Ausserdem POI Symbole kreieren oder holen
Damit die POIs angezeigt werden können, braucht jede ov2-Datei eine Bitmap-Bilddatei mit gleichem Namen (siehe Abschnitt Anleitung für Einsteiger).

Die Linux Variante:

ursprüngliche Kurzanleitung [1] und Schritt für Schritt Anleitung [2] und die ursprüngliche Methode [3]
wurde durch folgendes Verfahren wesentlich vereinfacht:

Diese Anleitung dient lediglich der Information - Benutzung auf eigene Gefahr !!!
Sollte aber auf allen Linux Distributionen funktionieren.
Benötigt werden lediglich die Pakete der Device-Mapper Tools ("dmsetup" auf Debian und Derivaten oder "device-mapper" auf RedHat/openSUSE und Derivaten),
und "perl", die auf allen Standardinstallationen vorhanden sein sollten.
Falls nicht, einfach mit der Paketverwaltung nachinstallieren

Zunächst bitte dieses Perl-Skript herunterladen: poorcase_1.1.pl.
( poorcase : A perl script to virtually reconstruct a split forensic disk image )
Dann kann das Dateisystem direkt auf der SD-Karte bearbeitet werden,
die unter <mountpoint> gemounted ist (in der Regel irgendwo unter /media/....):

mkdir ~/tomtom
sudo ~/poorcase_1.1.pl --build --name tomtom -o rw <mountpoint>/TOMTOM*
sudo mount /dev/mapper/tomtom ~/tomtom

Im Verzeichnis Europe "~/tomtom/common/installed/Europe"(hier liegt die Europakarte),
hier sind die eigenen POI-Dateien hineinzukopieren (*.ov2 und *.bmp).
Bei dieser Gelegenheit bietet sich auch gleich an die "unnötigen POI's" umzubenennen
Hat den Vorteil das sie im R-Link nicht mehr angezeigt werden :-)
POIs.JPG

Danach kann das Verzeichnis wieder ausgehängt werden, mit:

sudo umount /dev/mapper/tomtom
sudo ~/poorcase_1.1.pl --destroy --name tomtom <mountpoint>/TOMTOM*

Danach kann auch die SD-Karte "sicher ausgeworfen" und entfernt werden.
Nun ins Fahrzeug einsetzen und warten bis Kartenmaterial geladen wird.

Fertig !

R-Link-Explorer (Windows Variante)

Im französischen Tom-Tom-Forum gibt es die Software R-Link-Explorer, die die Files der SD-Karte unter Windows in einer Ansicht a la Total Commander darstellt.

R-Link Explorer von djeman13

Speicher Ort für die POI Dateien RLinkExplorerTarget.png

Direktlink Software:
Aktuell ist Version 1.2.2 - diese kann :

  • Kopieren / Verschieben (Drag / Drop)
  • Löschen
  • Umbenennen
  • Erstellen von Ordnern
  • Ändern Sie die Attribute (uid, gid, Berechtigungen)
  • Prüfen / Fix Dateisystemfehler
  • Erstellen Sie eine neue SD-Karte mit der Möglichkeit, Dateien aus dem alten importieren
  • Ändern Sie die Größe Volumen TOMTOM


Version 1.2.2: -> hier 
Version 1.2.1: -> hier
Version 1.1.1: -> hier 
Version 1.0.3: -> hier 
Version 1.0.0: -> hier

Kurzanleitung

Manuelles Backup erstellen: Den Inhalt der SD-Karte in einen Ordner auf den Computer kopieren. Automatisch wird eine Sicherungsdatei mit der RLinkToolbox (Download von MyRenault) erstellt, wenn ein Update anstand. Automatischer Start mit Windows bei der RLinkToolbox ausschalten. Programm RLinkToolbox schließen.

Nach dem Start vom R-Link Explorer auf No image open (rechtes Feld) klicken. Dann auf Open file (Datei --> Datei öffnen), hier auf die SD-Karte gehen und die Datei mit der Endung .000 auswählen. Dann den Pfad: ext00 -> common -> installed -> Europe (bzw. DE_AT_CH ). Dann Lokal Browser (linkes Feld) anklicken. Hier die z.B. drei Dateien auswählen und passende Bildsymbole (zur Darstellung im Navi). Vorher mit POI Generator erstellt. GEalleZoe.ov2 (rot), GEZoeKostenlos (gelb), GEZoeAktiv (ohne Störungsmeldung, grün). Copy (Bearbeiten --> Kopieren), rechtes Feld anklicken und Paste (Bearbeiten --> Einfügen) auswählen. Danach Close file anklicken (Datei --> Datei schließen). Sicheres Entfernen und die SD Karte im Zoe testen.

Nur wenn der R-Link Explorer die Datei beschädigt hat. Close file und Programm schließen. Start von der RLinkToolbox und die Sicherungsdatei wird auf die SD-Karte kopiert. Wenn die RLinkToolbox keine Sicherungsdatei bereithält, die Backupdateien vom Computer wieder auf die SD-Karte kopieren.

Anleitung für Einsteiger

Ein Update von R-Link-Software und -Apps kann über die Mobilfunk-Verbindung in Z.E. Fahrzeugen erfolgen. Nur für umfangreiche Dateien läuft das über den Händler oder, wie bei TomTom-Daten, über den heimischen Computer. Dazu holt man sich von Renault die Software R-Link-Toolbox. Bei anderen TomTom-Geräten benutzt man die TomTom Home-Software. Die beherrscht mehr als die RLinkToolbox, z.B. die Übertragung von eigenen POIs, weiteren Stimmen etc. Dies funktioniert bei Tom Tom Z.E. Carminat weniger komfortabel, d.h. ohne Kenntnis, wie mit einem Explorer-Programm Dateien verwaltet werden, läuft nix.

Für Windows gibt es dafür ein spezielles Programm, den R-Link-Explorer. Wo Windows auf der SD-Karte nur die Sammeldatei TOMTOM.000 sieht, werden mit dem R-Link-Explorer viele Dateien angezeigt. Darunter befinden sich TomTom-POI-Sammlungen (Dateien mit der Erweiterung .ov2) und zugehörige .bmp-Bitmap-Dateien, die jeweils ein Bildsymbol (Icon) für die gleichnamige POI-Sammlung enthalten. Wie RenaultTrucks.ov2 und RenaultTrucks.bmp.

In einer POI-Sammlung befinden sich z.B. alle Standorte von Geldautomaten oder RenaultTrucks-Servicestationen oder eben Stromladestationen. Bei denen ist es sinnvoll, für verschiedene Stecker (Typ2, CEE, Schuko) oder Ladekarten-Verbunde eigene POI-Sammlungen anzulegen und mit unterschiedlichen Symbolen anzuzeigen. Symbole werden mit Bitmap-Editoren erstellt; einige Forumsteilnehmer haben ihre Symbole für alle zur Verfügung gestellt. Du findest sie im Forumsbereich, suche mit "R-Link TomTom Symbole"

Die Symbole erstellt oder holt man sich einmal, die POI-Sammlung(en) erstellt man sich aus dem Stromtankstellenverzeichnis immer wieder neu und überträgt sie – anhand obiger Anleitung – auf die SD-Karte.

Weblinks