Ungelesene Beiträge - Bug

Ankündigungen, Anregungen, Kritik, Verbesserungsvorschläge

Re: Ungelesene Beiträge - Bug

Beitragvon Guy » Fr 19. Aug 2016, 11:14

Ein bisschen Hintergrundinformation.

Es gibt eine Tabelle in der Datenbank, in der gespeichert wird, wer wann zuletzt ein bestimmtes Thema besucht hat. Anhand dieser Tabelle wird ermittel, ob es Beiträge gibt, die nach dem gespeicherten Zeitpunkt geschrieben wurden. Falls ja, wird dieses Kästchen mit dem Link zum ersten neuen Beitrag angezeigt.

Ich habe allerdings noch nicht herausfinden können, wo in dieser Kette der Fehler ist. Entweder wird der Eintrag in der Tabelle nicht zuverlässig aktualisiert oder der Link zum ersten ungelesenen Beitrag nicht zuverlässig generiert oder der Eintrag wird aus irgendwelchen Gründen gelöscht.

Für meinen Account passt da leider alles.
Guy
Administrator
 
Beiträge: 3469
Registriert: Fr 26. Aug 2011, 14:52

Anzeige

Re: Ungelesene Beiträge - Bug

Beitragvon Jogi » Fr 19. Aug 2016, 11:30

Update:
Auf dem neuen PC funktioniert's in allen drei bisher getesteten Browsern (edge, Firefox und Chrome).

Mit dem alten PC probier ich's nochmal, sobald in den verdächtigen Threads neue Beiträge von anderen Usern gepostet wurden.
Wenn früher alles besser war,
hätte man's ja auch so lassen können.
Jogi
 
Beiträge: 2697
Registriert: Di 3. Apr 2012, 18:22

Re: Ungelesene Beiträge - Bug

Beitragvon Kellergeist2 » Fr 19. Aug 2016, 12:20

Jetzt bin ich hier schon wieder auf Seite 1 gelandet, obwohl der erste ungelesene Beitrag der erste von Seite 4 ist.
Könnte es damit zu tun haben, dass ein Seitenwechsel dazwischenliegt?

Darüber hinaus werden hier ja suchmaschinenfreundliche URLs generiert.
Möglicherweise passen unter bestimmten Umständen die in der Tabelle gespeicherten Informationen nicht zu den URLs in dem Link zum ersten ungelesenen Beitrag.
Fehler in den Rewrite-Konditionen?
Gruß, Kellergeist2
Tesla Model S 85
Kellergeist2
 
Beiträge: 258
Registriert: Di 29. Sep 2015, 20:00
Wohnort: Fürstenau

Re: Ungelesene Beiträge - Bug

Beitragvon Volker.Berlin » Fr 19. Aug 2016, 12:37

Kellergeist2 hat geschrieben:
Darüber hinaus werden hier ja suchmaschinenfreundliche URLs generiert.

Das ist tatsächlich ein Unterschied zum TFF-Forum.
Benutzeravatar
Volker.Berlin
 
Beiträge: 1781
Registriert: Mi 6. Feb 2013, 18:13

Re: Ungelesene Beiträge - Bug

Beitragvon Naheris » Fr 19. Aug 2016, 12:46

Auch ich habe den Fehler. Früher ist der sporadisch aufgetreten, aber derzeit ist es sehr extrem.

Meine Beobachtung: alle die "Hänger" entstehen grob zur selben Zeit, d.h. wenn die Threads hängen, dann alle einer oder eine Gruppe von zeitlich nah beieinander liegenden Sitzungen, in denen ich diese Threads gelesen habe. Spätere Sitzungen hängen sich scheinbar nicht neu auf, bis wieder ein Problem auftritt. Zumindest erscheint es mir so.

Wenn ein Thread mal hängt bleibt das so, zumindest sehr lange.

Es tritt bei mir in allen Browsern auf. Aber: es tritt nicht in denselben Threads gleichzeitig auf. Das unterscheidet sich nach Browsern.

Wenn man in einer Übersicht auf "neuen Beitrag lesen" drückt springt man immer zum selben alten Posting. In einem solchen Thread sind die Postings welche man noch nicht gelesen hat korrekt angezeigt (kleine orange Markierung oben). Wenn die Informationen des ersten ungelesenen Postings und der Sprung aus derselben Datenbanktabelle stammen, dann kann diese nicht das Problem sein.

Ich kann keine Gleichheiten bei den angesprungenen (falschen) Postings finden - oder denen direkt davor. Vielleicht ist eine Löschung ein Problem (die könnte ich nicht sehen).

Hier ein Thread für Dich von mir, bei dem es derzeit immer passiert (verlinkung auf die Posting, welche ich anspringe):
http://www.goingelectric.de/forum/goingelectric-forum/ungelesene-beitraege-bug-t18187.html#p381846
(das ist dieser Thread hier).

Ich kann noch mehr Beispiele liefern.
Ladeleistung und Übersicht derzeit gängiger EVs (Link im Forum)
Akkus der verschiedenen EVs (Link im Forum. Sammlung von m.k)
Fahrzeug: Passat GTE (ab 16.12.2016).

... and I paced.
Naheris
 
Beiträge: 332
Registriert: Fr 14. Aug 2015, 19:42

Re: Ungelesene Beiträge - Bug

Beitragvon Guy » Fr 19. Aug 2016, 14:43

Es gibt eine Option, die gelesenen Beiträge nicht in der Datenbank, sondern in den Cookies zu speichern. Der Nachteil dieser Lösung wäre allerdings, dass man dann auf unterschiedlichen Geräten unterschiedliche Datenstände hat - auch nicht wirklich schön.

Wäre vielleicht einen Versuch wert, um zu sehen, ob die Datenbank selbst das Problem ist oder es an einer anderen Stelle hakt.
Guy
Administrator
 
Beiträge: 3469
Registriert: Fr 26. Aug 2011, 14:52

Re: Ungelesene Beiträge - Bug

Beitragvon Elektrolurch » Fr 19. Aug 2016, 14:44

Guy hat geschrieben:
Es gibt eine Tabelle in der Datenbank, in der gespeichert wird, wer wann zuletzt ein bestimmtes Thema besucht hat. Anhand dieser Tabelle wird ermittel, ob es Beiträge gibt, die nach dem gespeicherten Zeitpunkt geschrieben wurden.

Wird diese Tabelle in irgendeiner Weise gecached?

Edit: Nicht nur beim Lesen, auch beim Schreiben?
Zuletzt geändert von Elektrolurch am Fr 19. Aug 2016, 14:47, insgesamt 1-mal geändert.
ZOE Intens Q210 weiß (F-Import) seit 11.2013
Benutzeravatar
Elektrolurch
 
Beiträge: 2442
Registriert: Fr 15. Nov 2013, 07:00
Wohnort: Ronnenberg-Benthe (Hannover)

Re: Ungelesene Beiträge - Bug

Beitragvon Elektrolurch » Fr 19. Aug 2016, 14:46

Keine Cookies um Himmels Willen! Ich behalte Cookies grundsätzlich nur für die Dauer der Sitzung. Dann würde das Forum für mich unbenutzbar...
ZOE Intens Q210 weiß (F-Import) seit 11.2013
Benutzeravatar
Elektrolurch
 
Beiträge: 2442
Registriert: Fr 15. Nov 2013, 07:00
Wohnort: Ronnenberg-Benthe (Hannover)

Re: Ungelesene Beiträge - Bug

Beitragvon Volker.Berlin » Fr 19. Aug 2016, 15:18

Ich möchte vorschlagen, einmal vorübergehend probehalber die suchmaschinenfreundlichen URLs abzuschalten, falls das auf einfache Weise möglich ist. Wenn das hilft, gibt es einen starken Hinweis darauf, wo das Problem zu suchen ist.

Cookies würden glaube ich, wie schon von Elektrolurch erwähnt, mehr neue Probleme verursachen, als sie lösen würden.
Benutzeravatar
Volker.Berlin
 
Beiträge: 1781
Registriert: Mi 6. Feb 2013, 18:13

Re: Ungelesene Beiträge - Bug

Beitragvon Guy » Fr 19. Aug 2016, 15:25

Nicht als dauerhafte Lösung, nur zum Testen. Wenn der Fehler dann immer noch auftritt, kann ich die Datenbank selbst als Ursache schon mal ausschließen.

Ich kann mir nur schwer vorstellen, dass es an den URLs liegt. Dies läuft bereits von Anfang an, ohne dass es daran irgendeine Änderung gegeben hat.
Guy
Administrator
 
Beiträge: 3469
Registriert: Fr 26. Aug 2011, 14:52

Anzeige

VorherigeNächste

Zurück zu GoingElectric Forum

 
  • Ähnliche Themen
    Antworten
    Zugriffe
    Letzter Beitrag
  • Ähnliche Artikel im Blog

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste